Debian Security Advisory

DLA-80-1 libxml2 -- LTS security update

Date Reported:
29 Oct 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-0191, CVE-2014-3660.
More information:

Sogeti found a denial of service flaw in libxml2, a library providing support to read, modify and write XML and HTML files. A remote attacker could provide a specially crafted XML file that, when processed by an application using libxml2, would lead to excessive CPU consumption (denial of service) based on excessive entity substitutions, even if entity substitution was disabled, which is the parser default behavior. (CVE-2014-3660)

In addition, this update addresses a misapplied chunk for a patch released the previous version (#762864).

For Debian 6 Squeeze, these issues have been fixed in libxml2 version 2.7.8.dfsg-2+squeeze10