Debian Security Advisory

DSA-2933-1 qemu-kvm -- security update

Date Reported:
19 May 2014
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 745157, Bug 725944.
In Mitre's CVE dictionary: CVE-2013-4344, CVE-2014-2894.
More information:

Several vulnerabilities were discovered in qemu-kvm, a full virtualization solution on x86 hardware.

  • CVE-2013-4344

    Buffer overflow in the SCSI implementation in QEMU, when a SCSI controller has more than 256 attached devices, allows local users to gain privileges via a small transfer buffer in a REPORT LUNS command.

  • CVE-2014-2894

    Off-by-one error in the cmd_smart function in the smart self test in hw/ide/core.c in QEMU allows local users to have unspecified impact via a SMART EXECUTE OFFLINE command that triggers a buffer underflow and memory corruption.

For the stable distribution (wheezy), these problems have been fixed in version 1.1.2+dfsg-6+deb7u3.

We recommend that you upgrade your qemu-kvm packages.