Debian Security Advisory

DSA-2982-1 ruby-activerecord-3.2 -- security update

Date Reported:
19 Jul 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-3482, CVE-2014-3483.
More information:

Sean Griffin discovered two vulnerabilities in the PostgreSQL adapter for Active Record which could lead to SQL injection.

For the stable distribution (wheezy), these problems have been fixed in version 3.2.6-5+deb7u1. Debian provides two variants of Ruby on Rails in Wheezy (2.3 and 3.2). Support for the 2.3 variants had to be ceased at this point. This affects the following source packages: ruby-actionmailer-2.3, ruby-actionpack-2.3, ruby-activerecord-2.3, ruby-activeresource-2.3, ruby-activesupport-2.3 and ruby-rails-2.3. The version of Redmine in Wheezy still requires 2.3, you can use an updated version from which is compatible with rails 3.2.

For the unstable distribution (sid), these problems have been fixed in version 3.2.19-1 of the rails-3.2 source package.

We recommend that you upgrade your ruby-activerecord-3.2 packages.