Bulletin d'alerte Debian

DSA-3005-1 gpgme1.0 -- Mise à jour de sécurité

Date du rapport :
14 août 2014
Paquets concernés :
gpgme1.0
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 756651.
Dans le dictionnaire CVE du Mitre : CVE-2014-3564.
Plus de précisions :

Tomáš Trnka a découvert un dépassement de tas dans la gestion d'état gpgsm de GPGME, une bibliothèque conçue pour faciliter l'accès des applications GnuPG. Un attaquant pourrait utiliser ce problème pour provoquer le plantage (déni de service) d'une application utilisant GPGME ou éventuellement pour exécuter du code arbitraire.

Pour la distribution stable (Wheezy), ce problème a été corrigé dans la version 1.2.0-1.4+deb7u1.

Pour la distribution testing (Jessie), ce problème a été corrigé dans la version 1.5.1-1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 1.5.1-1.

Nous vous recommandons de mettre à jour vos paquets gpgme1.0.