Debian Security Advisory

DSA-3017-1 php-cas -- security update

Date Reported:
02 Sep 2014
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 759718.
In Mitre's CVE dictionary: CVE-2014-4172.
More information:

Marvin S. Addison discovered that Jasig phpCAS, a PHP library for the CAS authentication protocol, did not encode tickets before adding them to an URL, creating a possibility for cross site scripting.

For the stable distribution (wheezy), this problem has been fixed in version 1.3.1-4+deb7u1.

The unstable distribution (sid) will be fixed soon.

We recommend that you upgrade your php-cas packages.