Debian Security Advisory

DSA-3034-1 iceweasel -- security update

Date Reported:
25 Sep 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-1568.
More information:

Antoine Delignat-Lavaud from Inria discovered an issue in the way NSS (the Mozilla Network Security Service library, embedded in Wheezy's Iceweasel package), was parsing ASN.1 data used in signatures, making it vulnerable to a signature forgery attack.

An attacker could craft ASN.1 data to forge RSA certificates with a valid certification chain to a trusted CA.

For the stable distribution (wheezy), this problem has been fixed in version 24.8.1esr-1~deb7u1.

For the testing distribution (jessie) and unstable distribution (sid), Iceweasel uses the system NSS library, handled in DSA 3033-1.

We recommend that you upgrade your iceweasel packages.