Debian Security Advisory

DSA-3077-1 openjdk-6 -- security update

Date Reported:
26 Nov 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-6457, CVE-2014-6502, CVE-2014-6504, CVE-2014-6506, CVE-2014-6511, CVE-2014-6512, CVE-2014-6517, CVE-2014-6519, CVE-2014-6531, CVE-2014-6558.
More information:

Several vulnerabilities have been discovered in OpenJDK, an implementation of the Oracle Java platform, resulting in the execution of arbitrary code, information disclosure or denial of service.

For the stable distribution (wheezy), these problems have been fixed in version 6b33-1.13.5-2~deb7u1.

We recommend that you upgrade your openjdk-6 packages.