Debian Security Advisory

DLA-127-1 pyyaml -- LTS security update

Date Reported:
03 Jan 2015
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 772815.
In Mitre's CVE dictionary: CVE-2014-9130.
More information:

Jonathan Gray and Stanislaw Pitucha found an assertion failure in the way wrapped strings are parsed in Python-YAML, a YAML parser and emitter for Python. An attacker able to load specially crafted YAML input into an application using python-yaml could cause the application to crash.

For Debian 6 Squeeze, these issues have been fixed in pyyaml version 3.09-5+deb6u1