Debian Security Advisory

DLA-150-1 unzip -- LTS security update

Date Reported:
07 Feb 2015
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 775640, Bug 776589.
In Mitre's CVE dictionary: CVE-2014-8139, CVE-2014-9636.
More information:

A flaw was found in the test_compr_eb() function allowing out-of-bounds read and write access to memory locations. By carefully crafting a corrupt ZIP archive an attacker can trigger a heap overflow, resulting in application crash or possibly having other unspecified impact.

Additionally this update corrects a defective patch applied to address CVE-2014-8139, which caused a regression with executable jar files.

For Debian 6 Squeeze, these issues have been fixed in unzip version 6.0-4+deb6u2