Debian Security Advisory

DLA-161-1 libgtk2-perl -- LTS security update

Date Reported:
28 Feb 2015
Affected Packages:
Security database references:
No other external database security references currently available.
More information:

It was discovered that libgtk2-perl, a Perl interface to the 2.x series of the Gimp Toolkit library, incorrectly frees memory which GTK+ still holds onto and might access later, leading to denial of service (application crash) or, potentially, to arbitrary code execution.

For Debian 6 Squeeze, these issues have been fixed in libgtk2-perl version 2:1.222-1+deb6u1