Debian Security Advisory

DLA-302-1 zendframework -- LTS security update

Date Reported:
27 Aug 2015
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2015-5161.
More information:

Dawid Golunski discovered that when running under PHP-FPM in a threaded environment, Zend Framework, a PHP framework, did not properly handle XML data in multibyte encoding. This could be used by remote attackers to perform an XML External Entity attack via crafted XML data.

For Debian 6 Squeeze, this issue has been fixed in zendframework version 1.10.6-1squeeze5.