Debian Security Advisory

DLA-329-1 postgresql-8.4 -- LTS security update

Date Reported:
19 Oct 2015
Affected Packages:
Security database references:
No other external database security references currently available.
More information:

Several bugs were discovered in PostgreSQL, a relational database server system. The 8.4 branch is EOLed upstream, but still present in Debian squeeze. This new LTS minor version contains the fixes that were applied upstream to the 9.0.22 version, backported to 8.4.22 which was the last version officially released by the PostgreSQL developers. This LTS effort for squeeze-lts is a community project sponsored by credativ GmbH.

Migration to Version 8.4.22lts5

A dump/restore is not required for those running 8.4.X. However, if you are upgrading from a version earlier than 8.4.22, see the relevant release notes.

Security Fixes

Fix contrib/pgcrypto to detect and report too-short crypt salts (Josh Kupershmidt)

Certain invalid salt arguments crashed the server or disclosed a few bytes of server memory. We have not ruled out the viability of attacks that arrange for presence of confidential information in the disclosed bytes, but they seem unlikely. (CVE-2015-5288)