Debian Security Advisory

DLA-361-1 bouncycastle -- LTS security update

Date Reported:
08 Dec 2015
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 802671.
In Mitre's CVE dictionary: CVE-2015-7940.
More information:

The Bouncy Castle Java library before 1.51 does not validate that a point is within the elliptic curve, which makes it easier for remote attackers to obtain private keys via a series of crafted elliptic curve Diffie Hellman (ECDH) key exchanges, aka an "invalid curve attack."

For Debian 6 Squeeze, this issue has been fixed in version 1.44+dfsg-2+deb6u1 of bouncycastle.

Many thanks to upstream author Peter Dettmann who reviewed the backport that we prepared.