Debian Security Advisory

DSA-3131-1 xdg-utils -- security update

Date Reported:
18 Jan 2015
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 773085.
In Mitre's CVE dictionary: CVE-2014-9622.
More information:

John Houwer discovered a way to cause xdg-open, a tool that automatically opens URLs in a user's preferred application, to execute arbitrary commands remotely.

For the stable distribution (wheezy), this problem has been fixed in version 1.1.0~rc1+git20111210-6+deb7u2.

For the upcoming stable (jessie) and unstable (sid) distributions, this problem has been fixed in version 1.1.0~rc1+git20111210-7.3.

We recommend that you upgrade your xdg-utils packages.