Debian Security Advisory

DSA-3138-1 jasper -- security update

Date Reported:
25 Jan 2015
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 775970.
In Mitre's CVE dictionary: CVE-2014-8157, CVE-2014-8158.
More information:

An off-by-one flaw, leading to a heap-based buffer overflow (CVE-2014-8157), and an unrestricted stack memory use flaw (CVE-2014-8158) were found in JasPer, a library for manipulating JPEG-2000 files. A specially crafted file could cause an application using JasPer to crash or, possibly, execute arbitrary code.

For the stable distribution (wheezy), these problems have been fixed in version 1.900.1-13+deb7u3.

For the upcoming stable distribution (jessie) and the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your jasper packages.