Debian Security Advisory

DSA-3217-1 dpkg -- security update

Date Reported:
09 Apr 2015
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2015-0840.
More information:

Jann Horn discovered that the source package integrity verification in dpkg-source can be bypassed via a specially crafted Debian source control file (.dsc). Note that this flaw only affects extraction of local Debian source packages via dpkg-source but not the installation of packages from the Debian archive.

For the stable distribution (wheezy), this problem has been fixed in version 1.16.16. This update also includes non-security changes previously scheduled for the next wheezy point release. See the Debian changelog for details.

For the unstable distribution (sid), this problem has been fixed in version 1.17.25.

We recommend that you upgrade your dpkg packages.