Debian Security Advisory

DSA-3339-1 openjdk-6 -- security update

Date Reported:
19 Aug 2015
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2015-2590, CVE-2015-2601, CVE-2015-2613, CVE-2015-2621, CVE-2015-2625, CVE-2015-2628, CVE-2015-2632, CVE-2015-2808, CVE-2015-4000, CVE-2015-4731, CVE-2015-4732, CVE-2015-4733, CVE-2015-4748, CVE-2015-4749, CVE-2015-4760.
More information:

Several vulnerabilities have been discovered in OpenJDK, an implementation of the Oracle Java platform, resulting in the execution of arbitrary code, breakouts of the Java sandbox, information disclosure, denial of service or insecure cryptography.

For the oldstable distribution (wheezy), these problems have been fixed in version 6b36-1.13.8-1~deb7u1.

We recommend that you upgrade your openjdk-6 packages.