Debian Security Advisory

DLA-445-2 squid3 -- LTS security update

Date Reported:
03 Mar 2016
Affected Packages:
squid3
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 816601.
In Mitre's CVE dictionary: CVE-2016-2569.
More information:

The backported patch to solve CVE-2016-2569 yielded to failed assertions that made squid3 to crash when closing connections. The fix for this CVE strongly relies on exception handling present in more recent versions of squid3, that I failed to identify in the previous update. I have reverted the patch to take the safest position, taking into account that Squeeze users should migrate to a supported version of Debian. This post-EOL update is intended to keep a functional squid3 package in the archive.