Debian Security Advisory

DSA-3487-1 libssh2 -- security update

Date Reported:
23 Feb 2016
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 815662.
In Mitre's CVE dictionary: CVE-2016-0787.
More information:

Andreas Schneider reported that libssh2, a SSH2 client-side library, passes the number of bytes to a function that expects number of bits during the SSHv2 handshake when libssh2 is to get a suitable value for group order in the Diffie-Hellman negotiation. This weakens significantly the handshake security, potentially allowing an eavesdropper with enough resources to decrypt or intercept SSH sessions.

For the oldstable distribution (wheezy), this problem has been fixed in version 1.4.2-1.1+deb7u2.

For the stable distribution (jessie), this problem has been fixed in version 1.4.3-4.1+deb8u1.

We recommend that you upgrade your libssh2 packages.