Debian Security Advisory

DSA-3561-1 subversion -- security update

Date Reported:
29 Apr 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2016-2167, CVE-2016-2168.
More information:

Several vulnerabilities were discovered in Subversion, a version control system. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2016-2167

    Daniel Shahaf and James McCoy discovered that an implementation error in the authentication against the Cyrus SASL library would permit a remote user to specify a realm string which is a prefix of the expected realm string and potentially allowing a user to authenticate using the wrong realm.

  • CVE-2016-2168

    Ivan Zhakov of VisualSVN discovered a remotely triggerable denial of service vulnerability in the mod_authz_svn module during COPY or MOVE authorization check. An authenticated remote attacker could take advantage of this flaw to cause a denial of service (Subversion server crash) via COPY or MOVE requests with specially crafted header.

For the stable distribution (jessie), these problems have been fixed in version 1.8.10-6+deb8u4.

For the unstable distribution (sid), these problems have been fixed in version 1.9.4-1.

We recommend that you upgrade your subversion packages.