Debian Security Advisory

DSA-3589-1 gdk-pixbuf -- security update

Date Reported:
30 May 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2015-7552, CVE-2015-8875.
More information:

Several vulnerabilities have been discovered in gdk-pixbuf, a toolkit for image loading and pixel buffer manipulation. A remote attacker can take advantage of these flaws to cause a denial-of-service against an application using gdk-pixbuf (application crash), or potentially, to execute arbitrary code with the privileges of the user running the application, if a malformed image is opened.

For the stable distribution (jessie), these problems have been fixed in version 2.31.1-2+deb8u5.

We recommend that you upgrade your gdk-pixbuf packages.