Debian Security Advisory

DSA-3636-1 collectd -- security update

Date Reported:
30 Jul 2016
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 832507, Bug 832577.
In Mitre's CVE dictionary: CVE-2016-6254.
More information:

Emilien Gaspar discovered that collectd, a statistics collection and monitoring daemon, incorrectly processed incoming network packets. This resulted in a heap overflow, allowing a remote attacker to either cause a DoS via application crash, or potentially execute arbitrary code.

Additionally, security researchers at Columbia University and the University of Virginia discovered that collectd failed to verify a return value during initialization. This meant the daemon could sometimes be started without the desired, secure settings.

For the stable distribution (jessie), this problem has been fixed in version 5.4.1-6+deb8u1.

For the testing (stretch) and unstable (sid) distributions, this problem has been fixed in version 5.5.2-1.

We recommend that you upgrade your collectd packages.