Debian Security Advisory

DSA-3640-1 firefox-esr -- security update

Date Reported:
03 Aug 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2016-2830, CVE-2016-2836, CVE-2016-2837, CVE-2016-2838, CVE-2016-5252, CVE-2016-5254, CVE-2016-5258, CVE-2016-5259, CVE-2016-5262, CVE-2016-5263, CVE-2016-5264, CVE-2016-5265.
More information:

Multiple security issues have been found in the Mozilla Firefox web browser: Multiple memory safety errors, buffer overflows and other implementation errors may lead to the execution of arbitrary code, cross-site scripting, information disclosure and bypass of the same-origin policy.

For the stable distribution (jessie), these problems have been fixed in version 45.3.0esr-1~deb8u1.

For the unstable distribution (sid), these problems have been fixed in version 45.3.0esr-1 for firefox-esr and 48.0-1 for firefox.

We recommend that you upgrade your firefox-esr packages.