Debian Security Advisory

DSA-3642-1 lighttpd -- security update

Date Reported:
05 Aug 2016
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 832571.
In Mitre's CVE dictionary: CVE-2016-1000212.
More information:

Dominic Scheirlinck and Scott Geary of Vend reported insecure behavior in the lighttpd web server. Lighttpd assigned Proxy header values from client requests to internal HTTP_PROXY environment variables, allowing remote attackers to carry out Man in the Middle (MITM) attacks or initiate connections to arbitrary hosts.

For the stable distribution (jessie), this problem has been fixed in version 1.4.35-4+deb8u1.

We recommend that you upgrade your lighttpd packages.