Debian Security Advisory

DSA-3646-1 postgresql-9.4 -- security update

Date Reported:
11 Aug 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2016-5423, CVE-2016-5424.
More information:

Several vulnerabilities have been found in PostgreSQL-9.4, a SQL database system.

  • CVE-2016-5423

    Karthikeyan Jambu Rajaraman discovered that nested CASE-WHEN expressions are not properly evaluated, potentially leading to a crash or allowing to disclose portions of server memory.

  • CVE-2016-5424

    Nathan Bossart discovered that special characters in database and role names are not properly handled, potentially leading to the execution of commands with superuser privileges, when a superuser executes pg_dumpall or other routine maintenance operations.

For the stable distribution (jessie), these problems have been fixed in version 9.4.9-0+deb8u1.

We recommend that you upgrade your postgresql-9.4 packages.