Debian Security Advisory

DSA-3716-1 firefox-esr -- security update

Date Reported:
16 Nov 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2016-5290, CVE-2016-5291, CVE-2016-5296, CVE-2016-5297, CVE-2016-9064, CVE-2016-9066, CVE-2016-9074.
More information:

Multiple security issues have been found in the Mozilla Firefox web browser: Multiple memory safety errors, buffer overflows and other implementation errors may lead to the execution of arbitrary code or bypass of the same-origin policy. Also, a man-in-the-middle attack in the addon update mechanism has been fixed.

For the stable distribution (jessie), these problems have been fixed in version 45.5.0esr-1~deb8u1.

For the unstable distribution (sid), these problems have been fixed in version 45.5.0esr-1 and version 50.0-1 of the firefox source package.

We recommend that you upgrade your firefox-esr packages.