Debian Security Advisory

DSA-3736-1 libupnp -- security update

Date Reported:
16 Dec 2016
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 831857, Bug 842093.
In Mitre's CVE dictionary: CVE-2016-6255, CVE-2016-8863.
More information:

Two vulnerabilities were discovered in libupnp, a portable SDK for UPnP devices.

  • CVE-2016-6255

    Matthew Garret discovered that libupnp by default allows any user to write to the filesystem of the host running a libupnp-based server application.

  • CVE-2016-8863

    Scott Tenaglia discovered a heap buffer overflow vulnerability, that can lead to denial of service or remote code execution.

For the stable distribution (jessie), these problems have been fixed in version 1:1.6.19+git20141001-1+deb8u1.

For the testing (stretch) and unstable (sid) distributions, these problems have been fixed in version 1:1.6.19+git20160116-1.2.

We recommend that you upgrade your libupnp packages.