Bulletin d'alerte Debian

DSA-3753-1 libvncserver -- Mise à jour de sécurité

Date du rapport :
5 janvier 2017
Paquets concernés :
libvncserver
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 850007, Bogue 850008.
Dans le dictionnaire CVE du Mitre : CVE-2016-9941, CVE-2016-9942.
Plus de précisions :

libvncserver, une collection de bibliothèques utilisées pour implémenter des serveurs et des clients VNC/RF, traitait incorrectement les paquets réseau entrants. Cela avait pour conséquence plusieurs dépassements de tas, permettant à un serveur intrus soit de provoquer un déni de service en plantant le client, soit éventuellement d'exécuter du code arbitraire côté client.

Pour la distribution stable (Jessie), ces problèmes ont été corrigés dans la version 0.9.9+dfsg2-6.1+deb8u2.

Pour la distribution testing (Stretch) et la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 0.9.11+dfsg-1.

Nous vous recommandons de mettre à jour vos paquets libvncserver.