Рекомендация Debian по безопасности

DSA-3753-1 libvncserver -- обновление безопасности

Дата сообщения:
05.01.2017
Затронутые пакеты:
libvncserver
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 850007, Ошибка 850008.
В каталоге Mitre CVE: CVE-2016-9941, CVE-2016-9942.
Более подробная информация:

Было обнаружено, что libvncserver, набор библиотек, используемых для реализации клиентов и серверов VNC/RFB, неправильно обрабатывает входящие сетевые пакеты. Это приводит к нескольким переполнениям динамической памяти, позволяющим серверу, контролируемому злоумышленником, либо вызывать отказ в обслуживании из-за аварийной остановки клиента, либо потенциально выполнять произвольный код на стороне клиента.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 0.9.9+dfsg2-6.1+deb8u2.

В тестируемом (stretch) и нестабильном (sid) выпусках эти проблемы были исправлены в версии 0.9.11+dfsg-1.

Рекомендуется обновить пакеты libvncserver.