Debian Security Advisory

DSA-3758-1 bind9 -- security update

Date Reported:
11 Jan 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 851062, Bug 851063, Bug 851065.
In Mitre's CVE dictionary: CVE-2016-9131, CVE-2016-9147, CVE-2016-9444.
More information:

Several denial-of-service vulnerabilities (assertion failures) were discovered in BIND, a DNS server implementation.

  • CVE-2016-9131

    A crafted upstream response to an ANY query could cause an assertion failure.

  • CVE-2016-9147

    A crafted upstream response with self-contradicting DNSSEC data could cause an assertion failure.

  • CVE-2016-9444

    Specially-crafted upstream responses with a DS record could cause an assertion failure.

These vulnerabilities predominantly affect DNS servers providing recursive service. Client queries to authoritative-only servers cannot trigger these assertion failures. These vulnerabilities are present whether or not DNSSEC validation is enabled in the server configuration.

For the stable distribution (jessie), these problems have been fixed in version 1:9.9.5.dfsg-9+deb8u9.

We recommend that you upgrade your bind9 packages.