Debian Security Advisory

DSA-3761-1 rabbitmq-server -- security update

Date Reported:
13 Jan 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 849849.
In Mitre's CVE dictionary: CVE-2016-9877.
More information:

It was discovered that RabbitMQ, an implementation of the AMQP protocol, didn't correctly validate MQTT (MQ Telemetry Transport) connection authentication. This allowed anyone to login to an existing user account without having to provide a password.

For the stable distribution (jessie), this problem has been fixed in version 3.3.5-1.1+deb8u1.

For the testing (stretch) and unstable (sid) distributions, this problem has been fixed in version 3.6.6-1.

We recommend that you upgrade your rabbitmq-server packages.