Debian Security Advisory

DSA-3772-1 libxpm -- security update

Date Reported:
26 Jan 2017
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2016-10164.
More information:

Tobias Stoeckmann discovered that the libXpm library contained two integer overflow flaws, leading to a heap out-of-bounds write, while parsing XPM extensions in a file. An attacker can provide a specially crafted XPM file that, when processed by an application using the libXpm library, would cause a denial-of-service against the application, or potentially, the execution of arbitrary code with the privileges of the user running the application.

For the stable distribution (jessie), this problem has been fixed in version 1:3.5.12-0+deb8u1. This update is based on a new upstream version of libxpm including additional bug fixes.

For the testing distribution (stretch) and the unstable distribution (sid), this problem has been fixed in version 1:3.5.12-1.

We recommend that you upgrade your libxpm packages.