Debian Security Advisory

DSA-3798-1 tnef -- security update

Date Reported:
01 Mar 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 856117.
In Mitre's CVE dictionary: CVE-2017-6307, CVE-2017-6308, CVE-2017-6309, CVE-2017-6310.
More information:

Eric Sesterhenn, from X41 D-Sec GmbH, discovered several vulnerabilities in tnef, a tool used to unpack MIME attachments of type application/ms-tnef. Multiple heap overflows, type confusions and out of bound reads and writes could be exploited by tricking a user into opening a malicious attachment. This would result in denial of service via application crash, or potential arbitrary code execution.

For the stable distribution (jessie), these problems have been fixed in version 1.4.9-1+deb8u1.

We recommend that you upgrade your tnef packages.