Debian Security Advisory
DSA-3862-1 puppet -- security update
- Date Reported:
- 25 May 2017
- Affected Packages:
- Security database references:
- In Mitre's CVE dictionary: CVE-2017-2295.
- More information:
It was discovered that unrestricted YAML deserialisation of data sent from agents to the server in the Puppet configuration management system could result in the execution of arbitrary code.
Note that this fix breaks backward compability with Puppet agents older than 3.2.2 and there is no safe way to restore it. This affects puppet agents running on Debian wheezy; we recommend to update to the puppet version shipped in wheezy-backports.
For the stable distribution (jessie), this problem has been fixed in version 3.7.2-4+deb8u1.
For the unstable distribution (sid), this problem has been fixed in version 4.8.2-5.
We recommend that you upgrade your puppet packages.