Debian Security Advisory

DSA-3874-1 ettercap -- security update

Date Reported:
09 Jun 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 857035, Bug 861604.
In Mitre's CVE dictionary: CVE-2017-6430, CVE-2017-8366.
More information:

Agostino Sarubbo and AromalUllas discovered that ettercap, a network security tool for traffic interception, contains vulnerabilities that allowed an attacker able to provide maliciously crafted filters to cause a denial-of-service via application crash.

For the stable distribution (jessie), these problems have been fixed in version 1:0.8.1-3+deb8u1.

For the upcoming stable (stretch) and unstable (sid) distributions, these problems have been fixed in version 1:0.8.2-4.

We recommend that you upgrade your ettercap packages.