Säkerhetsbulletin från Debian

DSA-3885-1 irssi -- säkerhetsuppdatering

Rapporterat den:
2017-06-18
Berörda paket:
irssi
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 864400.
I Mitres CVE-förteckning: CVE-2017-9468, CVE-2017-9469.
Ytterligare information:

Flera sårbarheter har upptäckts i Irssi, en terminalbaserad IRC-klient. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2017-9468

    Joseph Bisch upptäckte att Irssi inte hanterar DCC-meddelanden ordentligt utan ursprungs-nick/host. En illasinnad IRC-server kan dra fördel av denna brist för att orsaka att Irssi kraschar, vilket resulterar i överbelastning.

  • CVE-2017-9469

    Joseph Bisch upptäckte att Irssi inte hanterar mottagande av felaktigt citerade DCC-filer ordentligt. En illasinnad IRC-server kan dra fördel av denna brist för att orsaka att Irssi kraschar, vilket resulterar i överbelastning.

För den gamla stabila utgåvan (Jessie) har dessa problem rättats i version 0.8.17-1+deb8u4.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 1.0.2-1+deb9u1.

För den instabila distributionen (Sid) har dessa problem rättats i version 1.0.3-1.

Vi rekommenderar att ni uppgraderar era irssi-paket.