Debian Security Advisory

DSA-3942-1 supervisor -- security update

Date Reported:
13 Aug 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 870187.
In Mitre's CVE dictionary: CVE-2017-11610.
More information:

Calum Hutton reported that the XML-RPC server in supervisor, a system for controlling process state, does not perform validation on requested XML-RPC methods, allowing an authenticated client to send a malicious XML-RPC request to supervisord that will run arbitrary shell commands on the server as the same user as supervisord.

The vulnerability has been fixed by disabling nested namespace lookup entirely. supervisord will now only call methods on the object registered to handle XML-RPC requests and not any child objects it may contain, possibly breaking existing setups. No publicly available plugins are currently known that use nested namespaces. Plugins that use a single namespace will continue to work as before. Details can be found on the upstream issue at .

For the oldstable distribution (jessie), this problem has been fixed in version 3.0r1-1+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 3.3.1-1+deb9u1.

We recommend that you upgrade your supervisor packages.