Debians sikkerhedsbulletin

DSA-3979-1 pyjwt -- sikkerhedsopdatering

Rapporteret den:
19. sep 2017
Berørte pakker:
pyjwt
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2017-11424.
Yderligere oplysninger:

Man opdagede at PyJWT, en Python-implementering af JSON Web Token, udførte utilstrækkelig validering af nogle offentlig nøgle-typer, hvilket kunne gøre det muligt for en fjernangriber at fabrikere JWT'er helt fra begyndelsen.

I den gamle stabile distribution (jessie), er dette problem rettet i version 0.2.1-1+deb8u2.

I den stabile distribution (stretch), er dette problem rettet i version 1.4.2-1+deb9u1.

Vi anbefaler at du opgraderer dine pyjwt-pakker.