Рекомендация Debian по безопасности

DSA-3979-1 pyjwt -- обновление безопасности

Дата сообщения:
19.09.2017
Затронутые пакеты:
pyjwt
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2017-11424.
Более подробная информация:

Было обнаружено, что PyJWT, реализация JSON Web Token на языке Python, недостаточно проверяет некоторые виды открытых ключей, что может позволить удалённому злоумышленнику подделывать JWT.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 0.2.1-1+deb8u2.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 1.4.2-1+deb9u1.

Рекомендуется обновить пакеты pyjwt.