Säkerhetsbulletin från Debian

DSA-3982-1 perl -- säkerhetsuppdatering

Rapporterat den:
2017-09-21
Berörda paket:
perl
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 875596, Fel 875597.
I Mitres CVE-förteckning: CVE-2017-12837, CVE-2017-12883.
Ytterligare information:

Flera sårbarheter har upptäckts i implementationen av programmeringsspråket Perl. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2017-12837

    Jakub Wilk rapporterade ett heapbuffertspill i kompilatorn av reguljära uttryck, vilket tillåter en fjärrangripare att orsaka en överbelastning via ett speciellt skapat reguljärt uttryck med den skifteslägesokänslige modifieraren.

  • CVE-2017-12883

    Jakub Wilk rapporterade en buffer-överläsningsbrist i tolken av reguljära uttryck, vilket tillåter en fjärrangripare att orsaka en överbelastning eller informationsläckage.

För den gamla stabila utgåvan (Jessie) har dessa problem rättats i version 5.20.2-3+deb8u9.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 5.24.1-3+deb9u2.

För uttestningsutgåvan (Buster) har dessa problem rättats i version 5.26.0-8.

För den instabila distributionen (Sid) har dessa problem rättats i version 5.26.0-8.

Vi rekommenderar att ni uppgraderar era perl-paket.