Рекомендация Debian по безопасности

DSA-3984-1 git -- обновление безопасности

Дата сообщения:
26.09.2017
Затронутые пакеты:
git
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 876854.
В каталоге Mitre CVE: CVE-2017-14867.
Более подробная информация:

joernchen обнаружил, что git-cvsserver, подкоманда Git, распределённой системы управления версиями, подвержена введению команд командной оболочки в связи с небезопасным использованием оператора обратной галочки из языка Perl. Подкоманда git-cvsserver доступна из подкоманды git-shell даже в том случае, когда поддержка CVS не настроена (тем не менее, должен быть установлен пакет git-cvs).

Помимо исправления этой ошибки в данном обновлении по умолчанию удалена подкоманда cvsserver из git-shell. За инструкциями о том, как заново включить эту возможность CVS, если она вам нужна, обращайтесь к обновлённой документации.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 1:2.1.4-2.1+deb8u5.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 1:2.11.0-3+deb9u2.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1:2.14.2-1.

Рекомендуется обновить пакеты git.