Säkerhetsbulletin från Debian

DSA-3984-1 git -- säkerhetsuppdatering

Rapporterat den:
2017-09-26
Berörda paket:
git
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 876854.
I Mitres CVE-förteckning: CVE-2017-14867.
Ytterligare information:

joernchen upptäckte att underkommandot git-cvsserver i Git, ett distribuerat versionshanteringssystem, lider av en skalkommandoinjiceringssårbarhet på grund av osäker användning av Perls backtick-operator. Underkommandot git-cvsserver är nåbart från ett git-shell-underkommando även om CVS-stöd inte är konfigurerat (dock så måste paketet git-cvs vara installerat).

Utöver att rätta felet tar denna uppdatering bort underkommandot cvsserver från git-shell som standard. Hänvisa till den uppdaterade dokumentationen för instruktioner för hur du reaktiverar det om CVS-funktionaliteten fortfarande behövs.

För den gamla stabila utgåvan (Jessie) har detta problem rättats i version 1:2.1.4-2.1+deb8u5.

För den stabila utgåvan (Stretch) har detta problem rättats i version 1:2.11.0-3+deb9u2.

För den instabila distributionen (Sid) har detta problem rättats i version 1:2.14.2-1.

Vi rekommenderar att ni uppgraderar era git-paket.