Bulletin d'alerte Debian

DSA-4004-1 jackson-databind -- Mise à jour de sécurité

Date du rapport :
20 octobre 2017
Paquets concernés :
jackson-databind
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 870848.
Dans le dictionnaire CVE du Mitre : CVE-2017-7525.
Plus de précisions :

Liao Xinxi a découvert que jackson-databind, une bibliothèque Java d'analyse de JSON et d'autres formats de données, ne validait pas correctement les entrées de l'utilisateur avant de tenter la désérialisation. Cela permettait à un attaquant d'exécuter du code en fournissant une entrée contrefaite de façon malveillante.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 2.4.2-2+deb8u1.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 2.8.6-1+deb9u1.

Nous vous recommandons de mettre à jour vos paquets jackson-databind.