Debians sikkerhedsbulletin

DSA-4007-1 curl -- sikkerhedsopdatering

Rapporteret den:
27. okt 2017
Berørte pakker:
curl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2017-1000257.
Yderligere oplysninger:

Brian Carpenter, Geeknik Labs og 0xd34db347 opdagede at cURL, et URL-overførselsbibliotek, ukorrekt fortolkede et IMAP FETCH-svar med en størrelse på 0, førende til en læsning uden for grænserne.

I den gamle stabile distribution (jessie), er dette problem rettet i version 7.38.0-4+deb8u7.

I den stabile distribution (stretch), er dette problem rettet i version 7.52.1-5+deb9u2.

I den ustabile distribution (sid), er dette problem rettet i version 7.56.1-1.

Vi anbefaler at du opgraderer dine curl-pakker.