Säkerhetsbulletin från Debian

DSA-4009-1 shadowsocks-libev -- säkerhetsuppdatering

Rapporterat den:
2017-10-29
Berörda paket:
shadowsocks-libev
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2017-15924.
Ytterligare information:

Niklas Abel upptäckte att otillräcklig rengörning av indata i ss-manager-komponenten av shadowsocks-libev, en lättviktig socks5-proxy, kunde resultera i godtycklig exekvering av skalkommandon.

För den stabila utgåvan (Stretch) har detta problem rättats i version 2.6.3+ds-3+deb9u1.

Vi rekommenderar att ni uppgraderar era shadowsocks-libev-paket.