Рекомендация Debian по безопасности

DSA-4010-1 git-annex -- обновление безопасности

Дата сообщения:
30.10.2017
Затронутые пакеты:
git-annex
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 873088.
В каталоге Mitre CVE: CVE-2017-12976.
Более подробная информация:

Было обнаружено, что git-annex, инструмент для управления файлами с помощью git без проверки их содержимого, неправильно обрабатывает специально сформированные URL вида ssh://. Это позволяет злоумышленнику запускать произвольные команды командной оболочки.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 5.20141125+deb8u1.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 6.20170101-1+deb9u1.

Рекомендуется обновить пакеты git-annex.