Säkerhetsbulletin från Debian

DSA-4023-1 slurm-llnl -- säkerhetsuppdatering

Rapporterat den:
2017-11-07
Berörda paket:
slurm-llnl
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 880530.
I Mitres CVE-förteckning: CVE-2017-15566.
Ytterligare information:

Ryan Day upptäckte att Simple Linux Utility for Resource Management (SLURM), en klusterresurshanterare och jobbschemaläggarsystem inte hanterar SPANK-miljövariabler ordentligt, vilket tillåter en användare som har tillåtelse att skicka jobb och köra kod som root under Prolog eller Epilog. Alla system som använder Prolog- eller Epilog-skript är sårbara, oavsett om SPANK-insticksmoduler är i användning.

För den stabila utgåvan (Stretch) har detta problem rättats i version 16.05.9-1+deb9u1.

För den instabila distributionen (Sid) har detta problem rättats i version 17.02.9-1.

Vi rekommenderar att ni uppgraderar era slurm-llnl-paket.