Рекомендация Debian по безопасности

DSA-4032-1 imagemagick -- обновление безопасности

Дата сообщения:
12.11.2017
Затронутые пакеты:
imagemagick
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 873134, Ошибка 873099, Ошибка 878508, Ошибка 878507, Ошибка 876097, Ошибка 878527, Ошибка 876488, Ошибка 878562.
В каталоге Mitre CVE: CVE-2017-12983, CVE-2017-13134, CVE-2017-13758, CVE-2017-13769, CVE-2017-14224, CVE-2017-14607, CVE-2017-14682, CVE-2017-14989, CVE-2017-15277.
Более подробная информация:

Данное обновление исправляет несколько уязвимостей в imagemagick: различные проблемы работы с памятью, а также отсутствие очистки или неполная очистка входных данных могут приводить к отказу в обслуживании, раскрытию содержимого памяти или выполнению произвольного кода в случае обработки специально сформированных файлов GIF, TTF, SVG, TIFF, PCX, JPG или SFW.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 8:6.9.7.4+dfsg-11+deb9u3.

Рекомендуется обновить пакеты imagemagick.