Debians sikkerhedsbulletin

DSA-4042-1 libxml-libxml-perl -- sikkerhedsopdatering

Rapporteret den:
19. nov 2017
Berørte pakker:
libxml-libxml-perl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 866676.
I Mitres CVE-ordbog: CVE-2017-10672.
Yderligere oplysninger:

En sårbarhed i forbindelse med anvendelse efter frigivelse blev opdaget i XML::LibXML, en Perl-grænseflade til biblioteket libxml2, hvilket gjorde det muligt for en angriber at udføre vilkårlig kode, ved at kontrollere parametrene til et replaceChild()-kald.

I den gamle stabile distribution (jessie), er dette problem rettet i version 2.0116+dfsg-1+deb8u2.

I den stabile distribution (stretch), er dette problem rettet i version 2.0128+dfsg-1+deb9u1.

Vi anbefaler at du opgraderer dine libxml-libxml-perl-pakker.

For the detailed security status of libxml-libxml-perl please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libxml-libxml-perl