Рекомендация Debian по безопасности

DSA-4042-1 libxml-libxml-perl -- обновление безопасности

Дата сообщения:
19.11.2017
Затронутые пакеты:
libxml-libxml-perl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 866676.
В каталоге Mitre CVE: CVE-2017-10672.
Более подробная информация:

В XML::LibXML, Perl-интерфейсе к библиотеке libxml2, было обнаружено использование указателей после освобождения памяти, позволяющее злоумышленнику выполнять произвольный код, управляя аргументами вызова replaceChild().

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 2.0116+dfsg-1+deb8u2.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 2.0128+dfsg-1+deb9u1.

Рекомендуется обновить пакеты libxml-libxml-perl.

С подробным статусом поддержки безопасности libxml-libxml-perl можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libxml-libxml-perl